vGRID M365 Backup Jobs running slowly
Minor incident
vGRID Data Protection Services
vGRID Microsoft 365 Backup Platform
2026-05-03 16:09 NZST
· 4 days, 16 hours, 7 minutes
Updates
Resolved
May 8, 2026 · 08:07 NZST
The vGRID hosted Microsoft 365 backups are now back to running at normal operational speeds and jobs are completing within their expected backup windows.
Monitoring
May 3, 2026 · 16:09 NZST
The vGRID hosted Microsoft 365 backup jobs are currently running slower than expected. This may cause delays with some backups over the next few days.
We will continue to monitor and will advise once we see normal operational speeds return.
← Back